package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\S+) (.+)`)
var str = `add asdf asdf asdf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}