$re = '/(?:\?|\&)(?<key>[\w-]+)(?:\=?|)(?<value>[\w.]+)?/m';
$str = '.css?v=1.0&active&media=screen&font-weight=normal';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);