# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:(?:import|export)[^`'\"]*from\s+[`'\"])(?<from>[^`'\"./][^`'\"]*)(?:[`'\"])|(?:\bimport)(?:\s+|\s*\(\s*)(?:[`'\"])(?<plain>[^`'\"./][^`'\"]*)(?:[`'\"])"
test_str = ("import { defaultTemplateProcessor } from './lib/default-template-processor.js';\n"
"import { SVGTemplateResult, TemplateResult } from './lib/template-result.js';\n"
"export { DefaultTemplateProcessor, defaultTemplateProcessor } from './lib/default-template-processor.js';\n"
"export { directive, isDirective } from './lib/directive.js';\n"
"export { removeNodes, reparentNodes } from './lib/dom.js';\n"
"export { noChange, nothing } from './lib/part.js';\n"
"export { AttributeCommitter, AttributePart, BooleanAttributePart, EventPart, isIterable, isPrimitive, NodePart, PropertyCommitter, PropertyPart } from './lib/parts.js';\n"
"export { parts, render } from './lib/render.js';\n"
"export { templateCaches, templateFactory } from './lib/template-factory.js';\n"
"export { TemplateInstance } from './lib/template-instance.js';\n"
"export { SVGTemplateResult, TemplateResult } from './lib/template-result.js';\n"
"export { createMarker, isTemplatePartActive, Template } from './lib/template.js';\n"
"import { render } from 'lit-html/lib/shady-render.js';\n"
"import { UpdatingElement } from './lib/updating-element.js';\n"
"export * from './lib/updating-element.js';\n"
"export * from './lib/decorators.js';\n"
"export { html, svg, TemplateResult, SVGTemplateResult } from 'lit-html/lit-html.js';\n"
"import { supportsAdoptingStyleSheets } from './lib/css-tag.js';\n"
"export * from './lib/css-tag.js';\n"
"import { LitElement } from 'lit-element';\n"
"import { IronMeta } from '@polymer/iron-meta/iron-meta.js';\n"
"import { whenOnline } from 'hadron-core/lib/utils/async.js';\n"
"import { apiUrl, apiVersion } from '../../src/config.js';\n"
"import { importModule, dynamicImportAvailable } from '../../src/dynamic-imports-polyfill.js';\n"
"import observeProperties from 'hadron-core/lib/utils/object-property-observer.js';\n"
"export { version };\n"
"import { ElementMixin, version } from './lib/mixins/element-mixin.js';\n"
"export { html } from './lib/utils/html-tag.js';\n\n"
"class Foo {\n\n"
" constructor() {\n"
" import(`foo.js`);\n"
" import(`${foo}`);\n"
" import('bar.js');\n"
" } \n\n"
"}")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.