// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:(?:2[0-4][0-9]|25[0-5]|1?[0-9]?[0-9])\.){3}(?:2[0-4][0-9]|25[0-5]|[0-1]?[0-9]?[0-9])$").unwrap();
let string = "172.16.254.1
(?>!000|00|0)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}