package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[\[([\w\d\s]+)(?:\/.+|)\]\]`)
var str = `[[Test]]
[[Test Page]]
[[Test Page/Header]]
[[Test Page/Header 2]]
[[Test Page/Header 2]]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}