$re = '/<(\w+)>(.+)<\/\1>/';
$str = '<strong>hello world</strong>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);