const regex = /^\+?[1]?[2-9]{1}11$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\+?[1]?[2-9]{1}11$', 'gm')
const str = `211
311
411
511
611
711
811
911
+211
+311
+411
+511
+611
+711
+811
+911
+1211
+1311
+1411
+1511
+1611
+1711
+1811
+1911
2114123
+2114123
+12114123
911911
411411
311511
+911911
+4119`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}