package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(221|00221|\+221)?(77|78|75|70|76)[0-9]{7}$`)
var str = `00221704662238`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}