using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<scheme>[a-zA-Z][a-zA-Z0-9-+.]*)://(?:(?<username>(?:[\w-]|%\d\d)+)(?::(?<passwd>(?:[\w-]|%\d\d)*))?@)?(?<host>(?:[a-zA-Z][a-zA-Z0-9-]*\.?)+|\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})(?<port>:\d+)?(?<path>(?:/(?:[\w-.:]|%\d\d)+)+/?|/)?(?<query>\?(?:(?:[\w-]|%\d\d)+(?:=[\w]+)?(?:&|$))*)?(?<fragment>#.*)?$";
string input = @"https://en.wikipedia.org/wiki/Uniform_Resource_Identifier#Syntax
(↑ assuming URL, not URI; the only difference is that the host is mandatory)
https://regex101.com/
https://e./
https://org.
https://elearning.tgm.ac.at/pluginfile.php/297744/mod_resource/content/0/SEW5_UML_Einfuehrung.pdf
https://elearning.tgm.ac.at/mod/page/view.php?id%40_-ae=212356
https://elearning.tgm.ac.at/mod/assign/view.php?id=212239
https://elearning.tgm.ac.at/course/view.php?id=5454§ion=4
nonstandardscheme://is.still.valid
http://he.e/?
https://hy.a?a
http://h.?a&b&c=a
https://e.o.a.
http://0riedler:0%20tab-a_sco@riedler.a.wien/
http://emptypasswd:@riedler.wien/
http://a.e:33/
https://de.wikipedia.org/wiki/Wikipedia:Hauptseite
https://de.wikipedia.org/wiki/Preiselbeersauce#Zubereitung
https://toptoptoptoptoptoptoptoptoptoptoptoptoptoptoptoptoptoptoptop.top/
https://9.9.9.9/ipv4
https://2620:fe::fe/ipv6
ipv6 addresses are their own source of evil, not implementing those for now";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}