import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([ \\t]*)import [*] as (\\w+) from (?:(['])((?:(?:\\.)+|[^\\n\\r'\\\\]+)+)[']|([\"])((?:(?:\\.)+|[^\\n\\r'\\\\]+)+)[\"])";
final String string = "import * as Atblock from \"./atblock\"\n"
+ "import * as Atrule from \"./atrule\"\n"
+ "import * as Supports from \"./supports\"\n\n"
+ "import * as Node from './node';\n"
+ "import * as Root from './root'\n"
+ "import Null from './null'\n"
+ "import * as Each from './each'\n"
+ "import * as If from './if'\n"
+ "import * as Call from './call'\n"
+ "import * as UnaryOp from './unaryop'\n"
+ "import * as BinOp from './binop'\n"
+ "import * as Ternary from './ternary'\n"
+ "import * as Block from './block'\n"
+ "import * as Unit from './unit'\n"
+ "import * as String from './string'\n"
+ "import * as HSLA from './hsla'\n"
+ "import * as RGBA from './rgba'\n"
+ "import * as Ident from './ident'\n"
+ "import * as Group from './group'\n"
+ "import * as Literal from './literal'\n"
+ "import * as Boolean from './boolean'\n"
+ "import * as Return from './return'\n"
+ "import * as Media from './media'\n"
+ "import * as QueryList from './query-list'\n"
+ "import * as Query from './query'\n"
+ "import * as Feature from './feature'\n"
+ "import * as Params from './params'\n"
+ "import * as Comment from './comment'\n"
+ "import * as Keyframes from './keyframes'\n"
+ "import * as Member from './member'\n"
+ "import * as Charset from './charset'\n"
+ "import * as Namespace from './namespace'\n"
+ "import * as Import from './import'\n"
+ "import * as Extend from './extend'\n"
+ "import * as Object from './object'\n"
+ "import * as Function from './function'\n"
+ "import * as Property from './property'\n"
+ "import * as Selector from './selector'\n"
+ "import * as Expression from './expression'\n"
+ "import * as Arguments from './arguments'\n"
+ "import * as Atblock from './atblock'\n"
+ "import * as Atrule from './atrule'\n"
+ "import * as Supports from './supports'\n";
final String subst = "$1import $2 from $3$5$6$4$3$5";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}