const regex = /.*?(title|english|native)"\s?:\s?"(t).*?year"\s?:(2023).*?season"\s?:\"(winter)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*?(title|english|native)"\\s?:\\s?"(t).*?year"\\s?:(2023).*?season"\\s?:\\"(winter)', 'gmi')
const str = `[{"number":1,"title":"Tomo-chan wa Onnanoko!","native":"トモちゃんは女の子!","english":"Tomo-chan Is a Girl!","alternative":"Tomo-chan wa Onna no ko!","status":"Airing","year":2023,"season":"Winter","score":7.4,"episode":13,"duration":24,"released":"5 January 2023","type":"TV","image":"http://themeproject.test/wp-content/uploads/2023/03/bx151806-IAMi2ctI5xJI-20230308-021806.jpg","background":"http://themeproject.test/wp-content/uploads/2023/03/151806-1AmWChFo1Ogh.jpg","trailer":"","synopsis":"Tomboy Tomo couldn’t have picked a more awkward high school crush ’cause it’s on her childhood friend, Junichiro, but he only sees her as one of the guys. Despite her pretty looks and signals, nothing gets through to this meathead! Will Junichiro ever realize Tomo’s into him and see her for the cutesy girl she actually is?!-nl-(Source: Crunchyroll) -nl-"}]
[{"number":1,"title":"The Angel Next Door Spoils Me Rotten","native":"お隣の天使様にいつの間にか駄目人間にされていた件","english":"The Angel Next Door Spoils Me Rotten","alternative":"The Angel Next Door Spoils Me Rotten","status":"Airing","year":2023,"score":8,"duration":24,"trailer":"","episode":12,"season":"Winter","released":"1/7/2023","image":"http://themeproject.test/wp-content/uploads/2023/03/7X3FxgUOkViUmAePd3kUuHmfn.jpg","background":"http://themeproject.test/wp-content/uploads/2023/03/2tpxFqUTjJFOqI62rYndu3zbdu6.jpg","synopsis":"Amane lives alone in an apartment, and the most beautiful girl in school, Mahiru, lives just next door. They-sq-ve almost never spoken—until the day he sees her in distress on a rainy day and lends her his umbrella. To return the favour, she offers him help around the house, and a relationship slowly begins to blossom as the distance between them closes…","type":"TV"}]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}