package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)The puctuation character in the ASCII table are: !"#\$%&'\(\)\*\+,-\.\/:;<=>\?@\[\\]\^_`\{\|}~`)
var str = `The puctuation character in the ASCII table are: !"#$%&'()*+,-./:;<=>?@[\]^_\`{|}~
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}