re = /^(?P<asset>[A-Z]+)_(?P<side>C|L|R)_(?P<object>[A-Za-z0-9]+)_(?P<type>grp|ctrl|jnt|jntEnd|geo|loc|clstr|cls|crv|nbs|ikhl|cloth|nCloth|nucleus|ncls|foll|flc|hair|nHair|dist)$/m
str = 'GORDON_L_upperLeg_jnt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end