#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<date>\d{4}-\d{1,2}-\d{1,2})T(?<time>\d{1,2}:\d{1,2}:\d{1,2})\+\d{1,2}:\d{1,2}\s(?<level>\w+\s\(\d\)):\s(?<msg>.*$)"
Local $sString = "2015-10-23T14:48:03+00:00 INFO (6): NewProducts:: Observed customer login event" & @CRLF & _
"2015-10-23T14:48:03+00:00 DEBUG (7): NewProducts:: Customer is not checking out" & @CRLF & _
"2015-10-23T14:48:11+00:00 NOTICE (5): Freee" & @CRLF & _
"2015-10-23T14:48:24+00:00 NOTICE (5): Freee" & @CRLF & _
"2015-10-23T14:48:48+00:00 NOTICE (5): Freee" & @CRLF & _
"2015-10-23T14:48:58+00:00 NOTICE (5): Freee" & @CRLF & _
"2015-10-23T14:49:02+00:00 NOTICE (5): Freee" & @CRLF & _
"2015-10-23T14:49:02+00:00 NOTICE (5): Freee" & @CRLF & _
"2015-10-23T14:49:04+00:00 DEBUG (7): New Order being placed!" & @CRLF & _
"2015-10-23T14:49:04+00:00 DEBUG (7): This order has been preapproved" & @CRLF & _
"2015-10-23T14:49:04+00:00 DEBUG (7): Setting order state/status to approved/approved" & @CRLF & _
"2015-10-23T14:49:04+00:00 DEBUG (7): Captured Order Status Change Event" & @CRLF & _
"2015-10-23T14:49:04+00:00 DEBUG (7): Captured Order Status Change Event" & @CRLF & _
"2015-10-23T14:49:06+00:00 DEBUG (7): parent says we can edit" & @CRLF & _
"2015-10-23T14:49:06+00:00 WARN (4): we cannot approve, so we cannot edit" & @CRLF & _
"2015-10-23T14:49:06+00:00 DEBUG (7): parent says we can cancel" & @CRLF & _
"2015-10-23T14:49:06+00:00 WARN (4): we cannot approve, so we cannot cancel" & @CRLF & _
"2015-10-23T14:49:07+00:00 DEBUG (7): getting order flag" & @CRLF & _
"2015-10-23T14:49:07+00:00 DEBUG (7): " & @CRLF & _
"2015-10-23T14:49:07+00:00 ERR (3): Array" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")