#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:http|https):\/\/((?:[\w-]+)(?:\.[\w-]+)+)(?:[\w.,@?^=%&:\/~+#-]*[\w@?^=%&\/~+#-])?"
Local $sString = "https://developer.mozilla.org/es/" & @CRLF & _
"" & @CRLF & _
"http://www.es.pornhub.com/" & @CRLF & _
"http://es.cumlouder.com/?nats=MTkzOC4xLjIuMi4wLjAuMC4wLjA" & @CRLF & _
"http://www.pornotube.com/orientation/straight/home/page/1" & @CRLF & _
"http://rubias19.com/" & @CRLF & _
"http://www.elreyx.com/" & @CRLF & _
"http://www.puritanas.com/" & @CRLF & _
"http://www.xvideos.com/" & @CRLF & _
"http://es.xhamster.com/" & @CRLF & _
"http://www.redtube.com/" & @CRLF & _
"http://es.cam4.com/" & @CRLF & _
"https://es.chaturbate.com/" & @CRLF & _
"http://new.bangbros.com/home.htm" & @CRLF & _
"http://www.brazzers.com/home/?nats=NDc1NzAzOjQ5MzoyNA,0,0,0,0" & @CRLF & _
"http://www.petardas.com/" & @CRLF & _
"http://www.poringa.net/" & @CRLF & _
"http://foxtube.com/" & @CRLF & _
"http://www.tubewolf.com/" & @CRLF & _
"http://www.youporn.com/" & @CRLF & _
"http://www.putalocura.com/" & @CRLF & _
"http://www.serviporno.com/" & @CRLF & _
"http://www.toropornohd.com/" & @CRLF & _
"http://www.aztepajas.com/" & @CRLF & _
"http://pornfun.com/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")