#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^(a(?1)b|)$"
Local $sString = "" & @CRLF & _
"aaaabbbb" & @CRLF & _
"ab" & @CRLF & _
"" & @CRLF & _
"aaabb" & @CRLF & _
"bbbaa" & @CRLF & _
"abab" & @CRLF & _
"abba" & @CRLF & _
"aabbb" & @CRLF & _
"bbb" & @CRLF & _
"aaa" & @CRLF & _
"aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaabbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbb" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")