$re = '/^[0-9a-fA-F]{24}$/';
$str = '5395d1546c958bfe237af64c';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);