$re = '/\s(\d\S*)\s/m';
$str = 'scsm 7.2.4.8023 LogRhythm System Monitor Agent for AIX';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);