$re = '/^(?=.*[a-zA-Z])[ a-zA-Z0-9_-]{2,11}$/';
$str = 'azecazxaezc';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);