package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z0-9._%+-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,63}$`)
var str = `Format: minimum 2 characters @ minimum 3 characters . 2 - 63 characters
the g modifier let's us match multiple times in one string. the m modifier is useful here because it lets us treat each line as a seperate entry. Though in practice you probably dont need it for a simple one line email field
Jim@stuff.co.uk
Jim@google.com
Henry@h.com
Joe @m.net
Joe@m.net
Joe@mo.net
Joe@sam.net
a@sam.net
mo@sam.org
12@sam.org
Jon@sam.c
Jon@sam.co
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}