package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[[a-zA-Z]öäüÖÄÜßèî* -]{3,128}+`)
var str = `fgbc`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}