$re = '/^(?!(Received.*88\.99\.88\.99.*mail\.bbbrucable\.net)).*$/i';
$str = 'Received: from [88.99.88.99] by mail.bbbrucable.net; Wed, 17 Dec 2008';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);