package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([a-z0-9_\.-]+\@[\da-z\.-]+\.[a-z\.]{2,6})$`)
var str = `ktrichas@gmail.com
papaki_papa@test-asd.sadf.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}