const regex = /((https?:\/\/(www\.flickr\.com\/photos\/.*|flic\.kr\/.*|www\.twitter\.com\/.*|twitter\.com\/.*|.*imgur\.com\/.*|img\.ly\/.*|instagr\.am\/p\/.*|instagram\.com\/p\/.*|www\.instagram\.com\/p\/.*|giphy\.com\/gifs\/.*|gph\.is\/.*|media\.giphy\.com\/media\/.*|linkedin\.com\/in\/.*|linkedin\.com\/pub\/.*|.*\.linkedin\.com\/in\/.*|.*\.linkedin\.com\/pub\/.*|linkedin\.com\/in\/.*|linkedin\.com\/company\/.*|.*\.linkedin\.com\/company\/.*|tumblr\.com\/.*|.*\.tumblr\.com\/post\/.*|.*youtube\.com\/watch.*|.*\.youtube\.com\/v\/.*|youtu\.be\/.*|.*\.youtube\.com\/user\/.*|.*\.youtube\.com\/.*#.*\/.*|m\.youtube\.com\/watch.*|m\.youtube\.com\/index.*|.*\.youtube\.com\/profile.*|.*\.youtube\.com\/view_play_list.*|.*\.youtube\.com\/playlist.*|www\.youtube\.com\/embed\/.*|youtube\.com\/gif.*|www\.youtube\.com\/gif.*|www\.youtube\.com\/attribution_link.*|youtube\.com\/attribution_link.*|youtube\.ca\/.*|youtube\.jp\/.*|youtube\.com\.br\/.*|youtube\.co\.uk\/.*|youtube\.nl\/.*|youtube\.pl\/.*|youtube\.es\/.*|youtube\.ie\/.*|it\.youtube\.com\/.*|youtube\.fr\/.*|vids\.myspace\.com\/index\.cfm\?fuseaction=vids\.individual&videoid.*|www\.myspace\.com\/index\.cfm\?fuseaction=.*&videoid.*|vine\.co\/v\/.*|www\.vine\.co\/v\/.*|www\.vimeo\.com\/groups\/.*\/videos\/.*|www\.vimeo\.com\/.*|vimeo\.com\/groups\/.*\/videos\/.*|vimeo\.com\/.*|vimeo\.com\/m\/#\/.*|player\.vimeo\.com\/.*|www\.vevo\.com\/watch\/.*|www\.vevo\.com\/video\/.*|www\.facebook\.com\/photo\.php.*|www\.facebook\.com\/video\.php.*|www\.facebook\.com\/.*\/posts\/.*|fb\.me\/.*|www\.facebook\.com\/.*\/photos\/.*|www\.facebook\.com\/.*\/videos\/.*|fb\.com|plus\.google\.com\/.*|www\.google\.com\/profiles\/.*|google\.com\/profiles\/.*|soundcloud\.com\/.*|soundcloud\.com\/.*\/.*|soundcloud\.com\/.*\/sets\/.*|soundcloud\.com\/groups\/.*|snd\.sc\/.*|open\.spotify\.com\/.*|spoti\.fi\/.*|play\.spotify\.com\/.*|grooveshark\.com\/.*))|(https:\/\/(www\.flickr\.com\/photos\/.*|flic\.kr\/.*|.*imgur\.com\/.*|www\.instagram\.com\/p\/.*|giphy\.com\/gifs\/.*|gph\.is\/.*|media\.giphy\.com\/media\/.*|linkedin\.com\/in\/.*|linkedin\.com\/pub\/.*|.*\.linkedin\.com\/in\/.*|.*\.linkedin\.com\/pub\/.*|linkedin\.com\/in\/.*|linkedin\.com\/company\/.*|.*\.linkedin\.com\/company\/.*|tumblr\.com\/.*|.*\.tumblr\.com\/post\/.*|.*youtube\.com\/watch.*|.*\.youtube\.com\/v\/.*|youtu\.be\/.*|.*\.youtube\.com\/playlist.*|www\.youtube\.com\/embed\/.*|youtube\.com\/gif.*|www\.youtube\.com\/gif.*|www\.youtube\.com\/attribution_link.*|youtube\.com\/attribution_link.*|youtube\.ca\/.*|youtube\.jp\/.*|youtube\.com\.br\/.*|youtube\.co\.uk\/.*|youtube\.nl\/.*|youtube\.pl\/.*|youtube\.es\/.*|youtube\.ie\/.*|it\.youtube\.com\/.*|youtube\.fr\/.*|vine\.co\/v\/.*|www\.vine\.co\/v\/.*|www\.vimeo\.com\/.*|vimeo\.com\/.*|player\.vimeo\.com\/.*|www\.vevo\.com\/watch\/.*|www\.vevo\.com\/video\/.*|www\.facebook\.com\/photo\.php.*|www\.facebook\.com\/video\.php.*|www\.facebook\.com\/.*\/posts\/.*|fb\.me\/.*|www\.facebook\.com\/.*\/photos\/.*|www\.facebook\.com\/.*\/videos\/.*|www\.facebook\.com\/events\/.*|plus\.google\.com\/.*|soundcloud\.com\/.*|soundcloud\.com\/.*\/.*|soundcloud\.com\/.*\/sets\/.*|soundcloud\.com\/groups\/.*|open\.spotify\.com\/.*|play\.spotify\.com\/.*)))/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((https?:\\\/\\\/(www\\.flickr\\.com\\\/photos\\\/.*|flic\\.kr\\\/.*|www\\.twitter\\.com\\\/.*|twitter\\.com\\\/.*|.*imgur\\.com\\\/.*|img\\.ly\\\/.*|instagr\\.am\\\/p\\\/.*|instagram\\.com\\\/p\\\/.*|www\\.instagram\\.com\\\/p\\\/.*|giphy\\.com\\\/gifs\\\/.*|gph\\.is\\\/.*|media\\.giphy\\.com\\\/media\\\/.*|linkedin\\.com\\\/in\\\/.*|linkedin\\.com\\\/pub\\\/.*|.*\\.linkedin\\.com\\\/in\\\/.*|.*\\.linkedin\\.com\\\/pub\\\/.*|linkedin\\.com\\\/in\\\/.*|linkedin\\.com\\\/company\\\/.*|.*\\.linkedin\\.com\\\/company\\\/.*|tumblr\\.com\\\/.*|.*\\.tumblr\\.com\\\/post\\\/.*|.*youtube\\.com\\\/watch.*|.*\\.youtube\\.com\\\/v\\\/.*|youtu\\.be\\\/.*|.*\\.youtube\\.com\\\/user\\\/.*|.*\\.youtube\\.com\\\/.*#.*\\\/.*|m\\.youtube\\.com\\\/watch.*|m\\.youtube\\.com\\\/index.*|.*\\.youtube\\.com\\\/profile.*|.*\\.youtube\\.com\\\/view_play_list.*|.*\\.youtube\\.com\\\/playlist.*|www\\.youtube\\.com\\\/embed\\\/.*|youtube\\.com\\\/gif.*|www\\.youtube\\.com\\\/gif.*|www\\.youtube\\.com\\\/attribution_link.*|youtube\\.com\\\/attribution_link.*|youtube\\.ca\\\/.*|youtube\\.jp\\\/.*|youtube\\.com\\.br\\\/.*|youtube\\.co\\.uk\\\/.*|youtube\\.nl\\\/.*|youtube\\.pl\\\/.*|youtube\\.es\\\/.*|youtube\\.ie\\\/.*|it\\.youtube\\.com\\\/.*|youtube\\.fr\\\/.*|vids\\.myspace\\.com\\\/index\\.cfm\\?fuseaction=vids\\.individual&videoid.*|www\\.myspace\\.com\\\/index\\.cfm\\?fuseaction=.*&videoid.*|vine\\.co\\\/v\\\/.*|www\\.vine\\.co\\\/v\\\/.*|www\\.vimeo\\.com\\\/groups\\\/.*\\\/videos\\\/.*|www\\.vimeo\\.com\\\/.*|vimeo\\.com\\\/groups\\\/.*\\\/videos\\\/.*|vimeo\\.com\\\/.*|vimeo\\.com\\\/m\\\/#\\\/.*|player\\.vimeo\\.com\\\/.*|www\\.vevo\\.com\\\/watch\\\/.*|www\\.vevo\\.com\\\/video\\\/.*|www\\.facebook\\.com\\\/photo\\.php.*|www\\.facebook\\.com\\\/video\\.php.*|www\\.facebook\\.com\\\/.*\\\/posts\\\/.*|fb\\.me\\\/.*|www\\.facebook\\.com\\\/.*\\\/photos\\\/.*|www\\.facebook\\.com\\\/.*\\\/videos\\\/.*|fb\\.com|plus\\.google\\.com\\\/.*|www\\.google\\.com\\\/profiles\\\/.*|google\\.com\\\/profiles\\\/.*|soundcloud\\.com\\\/.*|soundcloud\\.com\\\/.*\\\/.*|soundcloud\\.com\\\/.*\\\/sets\\\/.*|soundcloud\\.com\\\/groups\\\/.*|snd\\.sc\\\/.*|open\\.spotify\\.com\\\/.*|spoti\\.fi\\\/.*|play\\.spotify\\.com\\\/.*|grooveshark\\.com\\\/.*))|(https:\\\/\\\/(www\\.flickr\\.com\\\/photos\\\/.*|flic\\.kr\\\/.*|.*imgur\\.com\\\/.*|www\\.instagram\\.com\\\/p\\\/.*|giphy\\.com\\\/gifs\\\/.*|gph\\.is\\\/.*|media\\.giphy\\.com\\\/media\\\/.*|linkedin\\.com\\\/in\\\/.*|linkedin\\.com\\\/pub\\\/.*|.*\\.linkedin\\.com\\\/in\\\/.*|.*\\.linkedin\\.com\\\/pub\\\/.*|linkedin\\.com\\\/in\\\/.*|linkedin\\.com\\\/company\\\/.*|.*\\.linkedin\\.com\\\/company\\\/.*|tumblr\\.com\\\/.*|.*\\.tumblr\\.com\\\/post\\\/.*|.*youtube\\.com\\\/watch.*|.*\\.youtube\\.com\\\/v\\\/.*|youtu\\.be\\\/.*|.*\\.youtube\\.com\\\/playlist.*|www\\.youtube\\.com\\\/embed\\\/.*|youtube\\.com\\\/gif.*|www\\.youtube\\.com\\\/gif.*|www\\.youtube\\.com\\\/attribution_link.*|youtube\\.com\\\/attribution_link.*|youtube\\.ca\\\/.*|youtube\\.jp\\\/.*|youtube\\.com\\.br\\\/.*|youtube\\.co\\.uk\\\/.*|youtube\\.nl\\\/.*|youtube\\.pl\\\/.*|youtube\\.es\\\/.*|youtube\\.ie\\\/.*|it\\.youtube\\.com\\\/.*|youtube\\.fr\\\/.*|vine\\.co\\\/v\\\/.*|www\\.vine\\.co\\\/v\\\/.*|www\\.vimeo\\.com\\\/.*|vimeo\\.com\\\/.*|player\\.vimeo\\.com\\\/.*|www\\.vevo\\.com\\\/watch\\\/.*|www\\.vevo\\.com\\\/video\\\/.*|www\\.facebook\\.com\\\/photo\\.php.*|www\\.facebook\\.com\\\/video\\.php.*|www\\.facebook\\.com\\\/.*\\\/posts\\\/.*|fb\\.me\\\/.*|www\\.facebook\\.com\\\/.*\\\/photos\\\/.*|www\\.facebook\\.com\\\/.*\\\/videos\\\/.*|www\\.facebook\\.com\\\/events\\\/.*|plus\\.google\\.com\\\/.*|soundcloud\\.com\\\/.*|soundcloud\\.com\\\/.*\\\/.*|soundcloud\\.com\\\/.*\\\/sets\\\/.*|soundcloud\\.com\\\/groups\\\/.*|open\\.spotify\\.com\\\/.*|play\\.spotify\\.com\\\/.*)))', 'ig')
const str = `https://twitter.com/SND_TST
https://www.twitter.com/SND_TST/status/469979579168202752
http://www.youtube.com/watch?v=-50NdPawLVY`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}