re = /(([\W\w]*)(apps)(-?)([\w]{0,2})(.[\W\w]*))/
str = 'notificationcentermainui.apps.homedepot.com'
# Print the match result
str.match(re) do |match|
puts match.to_s
end