# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[^<>]*"
test_str = ("Searchers detect a signal from a missing plane, the U.S. government warns about travel to Europe, and ethical hackers test an organization's security.<div class=\"feedflare\">\n"
"<a href=\"http://rss.cnn.com/~ff/services/podcasting/studentnews/rss?a=pczyX_vUQDg:VFcvlifpcAA:yIl2AUoC8zA\"><img src=\"http://feeds.feedburner.com/~ff/services/podcasting/studentnews/rss?d=yIl2AUoC8zA\" border=\"0\"></img></a> <a href=\"http://rss.cnn.com/~ff/services/podcasting/studentnews/rss?a=pczyX_vUQDg:VFcvlifpcAA:7Q72WNTAKBA\"><img src=\"http://feeds.feedburner.com/~ff/services/podcasting/studentnews/rss?d=7Q72WNTAKBA\" border=\"0\"></img></a> <a href=\"http://rss.cnn.com/~ff/services/podcasting/studentnews/rss?a=pczyX_vUQDg:VFcvlifpcAA:V_sGLiPBpWU\"> <img src=\"http://feeds.feedburner.com/~ff/services/podcasting/studentnews/rss?i=pczyX_vUQDg:VFcvlifpcAA:V_sGLiPBpWU\" border=\"0\"></img></a> <a href=\"http://rss.cnn.com/~ff/services/podcasting/studentnews/rss?a=pczyX_vUQDg:VFcvlifpcAA:qj6IDK7rITs\"><img src=\"http://feeds.feedburner.com/~ff/services/podcasting/studentnews/rss?d=qj6IDK7rITs\" border=\"0\"></img></a> <a href=\"http://rss.cnn.com/~ff/services/podcasting/studentnews/rss?a=pczyX_vUQDg:VFcvlifpcAA:gIN9vFwOqvQ\"><img src=\"http://feeds.feedburner.com/~ff/services/podcasting/studentnews/rss?i=pczyX_vUQDg:VFcvlifpcAA:gIN9vFwOqvQ\" border=\"0\"></img></a></div><img src=\"http://feeds.feedburner.com/~r/services/podcasting/studentnews/rss/~4/pczyX_vUQDg\" height=\"1\" width=\"1\" alt=\"\"/>")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.