package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d{1,3}(-\d{1,3})?\.{1}){3}(\d{1,3}-?\d{1,3})$`)
var str = `192.168.0.1-255`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}