re = /(([0][1-9]|[1][0-2]):([0-5][0-9])([p][m]))|(([0][0-9]|[1][01]):([0-5][0-9])([a][m]))/
str = '00:59am'
# Print the match result
str.match(re) do |match|
puts match.to_s
end