$re = '/\[:(\w+)\]/m';
$str = ':\'my_service_data[:key1][:key2]\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);