use strict;
my $str = 'NM_12345.4:c.19999+500_20000+400del';
my $regex = qr/(?P<reference_sequence>(NM|NR|XM|XR)_[0-9]{4,12}|ENST[0-9]{1,11})(\.(?P<version>([0-9]?[0-9])))?(:(?P<prefix>c|n)\.(?P<start>-?[1-9][0-9]{0,7})(?P<start_offset>[+-][1-9][0-9]{0,7})?_(?P<end>-?[1-9][0-9]{0,7})(?P<end_offset>[+-][1-9][0-9]{0,7})?)del$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}