package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*?)(?:\(#\d+\))?$`)
var str = `Sales Ths. Ltr (#10)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}