$re = '/((?<=[\?\&])foo\=[^\&\#]*)|((?<=[\?\&])foo(?=[\&\#]))|((?<=[\?\&])foo(?!.))/';
$str = '?foo=bar&?foo&foo=foo&foo&nonfoo=bar&nonfoo&foo#foofoo
?foo=bar&?foo&foo=foo&foo&nonfoo=bar&nonfoo&foo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);