re = /(?:(?:.*?\|\s?){2})\[(.+?)\](?:(?=\s?$)|(?=\s?\|))/i
str = '[String1] |[String two is here]| [String 3] |[String-4]'
# Print the match result
str.match(re) do |match|
puts match.to_s
end