import Foundation
let pattern = #"^(\d{4}-?)?\d{2}-?\d{3}-?\d{4}$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"1234-99-123-4567"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}