#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?P<scheme>http(?:s)?:\/\/)?(?P<www>www\d?\.)?(?P<domain>\b(?!www\d?\.)[a-z\d\-]+(?:\.[a-z\d\-]{2,})+)(?P<port>:\d{1,5})?(?P<path>\/(?:[-a-zA-Z0-9._~!$&\'()*+,;=:@]|%[0-9a-fA-F]{2})*)*(?P<query_fragm>[?#&][\/\_\-\&\%\?\#\+\=\.:a-zA-Z\d]*)*$"
Local $sString = "http://example.com" & @CRLF & _
"https://www.example.com" & @CRLF & _
"http://example.com/path" & @CRLF & _
"https://www.example.com/path" & @CRLF & _
"http://example.com/path?query=1" & @CRLF & _
"https://www.example.com/path?query=1" & @CRLF & _
"http://example.com/path#fragment" & @CRLF & _
"https://www.example.com/path#fragment" & @CRLF & _
"http://example.com:8080" & @CRLF & _
"https://www.example.com:8080" & @CRLF & _
"http://subdomain.example.com" & @CRLF & _
"https://www.subdomain.example.com" & @CRLF & _
"http://subdomain.example.com/path" & @CRLF & _
"https://www.subdomain.example.com/path" & @CRLF & _
"http://subdomain.example.com/path?query=1" & @CRLF & _
"https://www.subdomain.example.com/path?query=1" & @CRLF & _
"http://subdomain.example.com/path#fragment" & @CRLF & _
"https://www.subdomain.example.com/path#fragment" & @CRLF & _
"http://subdomain.example.com:8080" & @CRLF & _
"https://www.subdomain.example.com:8080" & @CRLF & _
"http://example.org" & @CRLF & _
"https://www.example.org" & @CRLF & _
"http://example.org/path" & @CRLF & _
"https://www.example.org/path" & @CRLF & _
"http://example.org/path?query=1" & @CRLF & _
"https://www.example.org/path?query=1" & @CRLF & _
"http://example.org/path#fragment" & @CRLF & _
"https://www.example.org/path#fragment" & @CRLF & _
"http://example.org:8080" & @CRLF & _
"https://www.example.org:8080" & @CRLF & _
"http://subdomain.example.org" & @CRLF & _
"https://www.subdomain.example.org" & @CRLF & _
"http://subdomain.example.org/path" & @CRLF & _
"https://www.subdomain.example.org/path" & @CRLF & _
"http://subdomain.example.org/path?query=1" & @CRLF & _
"https://www.subdomain.example.org/path?query=1" & @CRLF & _
"http://subdomain.example.org/path#fragment" & @CRLF & _
"https://www.subdomain.example.org/path#fragment" & @CRLF & _
"http://subdomain.example.org:8080" & @CRLF & _
"https://www.subdomain.example.org:8080" & @CRLF & _
"http://example.net" & @CRLF & _
"https://www.example.net" & @CRLF & _
"http://example.net/path" & @CRLF & _
"https://www.example.net/path" & @CRLF & _
"http://example.net/path?query=1" & @CRLF & _
"https://www.example.net/path?query=1" & @CRLF & _
"http://example.net/path#fragment" & @CRLF & _
"https://www.example.net/path#fragment" & @CRLF & _
"http://example.net:8080" & @CRLF & _
"https://www.example.net:8080"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")