$re = '/^([0]{1}[1-9]{1}|[1-9]{1}[0-9]{1})[0-9]{3}$/';
$str = '48565';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);