re = /(?:console\.(?!log))/m
str = 'console.log(
console.stack(
consolelog(
console'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end