package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(10)$|^[0-9](\.[0-9])?$`)
var str = `9.5`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}