import Foundation
let pattern = #"^([^()[\]{}<>]*)(\(((?1)(?2)*)*\)|\[(?3)*\]|\<(?3)*\>|{(?3)*\})(?1)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"sd{f(tagsad<fas>df(tag(a)sd)sdfa(sdf)s[a(sd)]f)as}df"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}