$re = '/function\([\s]*?\'([\S]*?)\'[\s]*?,[\s]*?\'([\S]*?)\'[\s]*?,[\s]*?\'([\S]*?)\'[\s]*?,[\s]*?\'([\S]*?)\'\)/';
$str = 'function( \'12\', \'World34\' , \'456\' ,\'Hello\')';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);