# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\w+((-|\.|_)\w+)*\w*@\w+(-\w)?(\w*)?\.\w{2,3}(\.\w{2,3})?$"
test_str = ("# invalid email\n"
"abc\n"
"abc.com\n\n"
"# valid email address\n"
"abc@mail.com\n"
"abc@mail.nz\n"
"abc@mail.co.nz\n"
"abc123@mail.com\n"
"abc.def@music.com\n\n"
"# invalid email prefix\n"
"abc-@mail.com\n"
"abc..def@mail.com\n"
".abc@mail.com\n"
"abc#def@mail.com\n\n"
"# valid email prefix\n"
"abc-d@mail.com\n"
"abc.def@mail.com\n"
"abc@mail.com\n"
"abc_def@mail.com\n\n"
"# invalid domain suffix\n"
"abc.def@mail.c\n"
"abc.def@mail#archive.com\n"
"abc.def@mail\n"
"abc.def@mail..com\n\n"
"# valid domain suffix\n"
"abc.def@mail.cc\n"
"abc.def@mail-archive.com\n"
"abc.def@mail.org\n"
"abc.def@mail.com\n"
"fully-qualified-domain@example.com")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.