$re = '/[^A-Za-z0-9]/';
$str = '@" cash$ mon*&ey 213asdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);