const regex = new RegExp('([0-9]*\\.?[0-9]*)\\s*%', 'gmi')
const str = `(x-10)+1.23 * 40.014 dd % something else
(x\\1-0.3) + (y/1-.15)
(x\\(1/30.011%) + (y/(1/15%)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}