const regex = /<h[1-9]{1}\s*[id=".+"]*>.*[<\/h[1-9]{1}>]*/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<h[1-9]{1}\\s*[id=".+"]*>.*[<\\\/h[1-9]{1}>]*', 'gmu')
const str = `<img src="/images/anleitungen/backen/pizza_steinofen.jpg" style="display:inline-block; margin:10px; float:left;" alt="Steinofen für die perfekte Pizza">
<p>Die perfekte Pizza im Stile einer neapolitanischen oder römischen hat einen dünnen, knusprigen, aber nicht harten, sondern eher zart-knusprigen Boden. Optimale Bedingungen hierfür hat ein Steinofen mit Temperaturen bis zu 500 Grad. Jedoch dürften nur die wenigsten die Möglichkeiten haben, sich einen solchen zu Hause aufzustellen. Was das entscheidende bei der Zubereitung ist: möglichst hohe, direkte Hitze. Durch direkte Hitze, also das Aufliegen auf einer möglichst heißen Unterlage, wird erreicht, dass der Boden unten knusprig wird, die Auflage aber saftig bleibt.</p>
<p>Ein herkömmliches Backblech speichert nicht genügend Hitze, um diese Bedingungen zu erreichen. Ein wenig bessere Ergebnisse erzielt man mit einem Pizzablech, bei dem die Hitze entweder durch eingestanzte Löcher direkter zugeführt wird oder durch die erhöhte Dicke der Bleche eine größere Hitzespeicherung erreicht wird. Durch die Löcher kann auch die Feuchtigkeit entweichen, ein Effekt, der sonst durch die Aufnahmefähigkeit des Steins erreicht wird.</p>
<h2>Der Pizzastein</h2>
<p>Wesentlich besser ist die Verwendung eines Pizzasteins. Ein solcher Stein mit einer Dicke von 3, besser 4 cm speichert die Hitze und gibt sie direkt an die Pizza ab. Pizzasteine sind aus hitzebeständigem Schamott-Ton, wie er auch für die Innenräume von Öfen verwendet wird. Man kann sie im Fachhandel erwerben. Eine preiswerte Alternative sind Granitplatten, wie sie in jedem Baumarkt zu finden sind. Wichtig ist: der Stein sollte ausreichend dick und darf nicht glasiert sein. Granit hat übrigens neben dem geringeren Preis noch einen anderen Vorteil: Die Oberfläche ist feinporiger, übergelaufene Sauce oder Käse lassen sich so besser entfernen als von einem Schmottstein.</p>
<p><b>Wichtig:</b> Damit der Pizzastein seine Leistung entfalten kann, muss er ausreichend vorgeheizt sein. Das bedeutet, dass man ihn mindestens mindestens 15 Minuten nach erreichen der Betriebstemperatur noch weiter heizen sollte, bevor die erste Pizza in den Ofen kommt. Wer für mehr als 2 Personen Pizza backt, kann auch zwei Steine mit ausreichend Abstand übereinander in den Ofen schieben.</p>
<h3>Tipps und Tricks rund um den Pizzastein</h3>
<ul>
<li><strong>Ausreichend vorheizen</strong> <br />
Den Stein mit dem Ofen auf dem Rost auf unterster Einschubleiste aufheizen und nach erreichen der Betriebstemperatur mind. 20 Minuten warten.</li>
<li><strong>Belegen auf dem Schieber</strong><br />
Die Pizza direkt auf dem Schieber belegen und danach zügig einschießen, damit der Teig nicht aufweicht.</li>
<li><strong>Grieß als Unterlage</strong> <br />
Den Schieber mit Grieß bestreuen, damit die Pizza gut vom Schieber rutschen kann.</li>
<li><strong>Einschießen üben</strong><br />
Das Einschießen der Pizza auf den Stein am Besten vorher üben, um den richtigen Schwun zu testen: Erst mit unbelegtem, später mit belegtem Boden auf der Arbeitsplatte trainieren: Durch schnelles Vorstoßen und Zurückziehen gelangt die Pizza auf den Stein.</li>
<li><strong>Backpapier</strong> <br />
Wer unsicher ist, kann unter die Pizza ein ausrechend große Stück Backpapier legen. Vorsicht beim Rüberschieben auf den Stein ist dennoch geboten: der Stein ist sehr heiß!</li>
</ul>
<h2>Der Pizzaschieber / die Pizzaschaufel</h2>
<p>Da der Pizzastein sehr heiß und die Pizza sehr dünn und biegsam ist, kann sie nicht einfach auf den Stein gelegt werden. Zum Befördern auf den Pizzastein (Einschießen) verwendet man daher einen Pizzaschieber, auch Pizzaschaufel genannt: Ein dünnes Brett mit Griff, auf dem die Pizza iiegt und vom dem sie aus mit Ruckartiger Bewegung auf den Stein "geschossen" wird. Auch die Pizzaschaufel ist im Handel erhältlich. Handwerklich Begabte können sie jedoch auch aus dünnem Sperrholz selber zurecht sägen. Die Kanten mit Schmiergelpapier abflachen.</p>
<p>
Mit Pizzastein und Pizzaschaufel hat man das nötige Equipement für den heimischen Pizzaofen. Was jetzt noch fehlt ist der richtige Teig und ein aromatischer Sugo.</p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}