re = /(?=((A[TU]G)(?:.{3})*?(?:[TU]AG|[TU]AA|[TU]GA)))/i
str = 'tatgaatgaatgffffffatgfftaaftaafatgfatgfffffsdfatgffatgfffstaafftaafffffffffffffffatgtaaataa
atgffftaaf
atgffatgftaafftaa
atgatgtaataa
tttttttttttttaatgatgfffffffffftaa'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end