const regex = /^.*\.(txt|ZIP)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*\\.(txt|ZIP)$', '')
const str = `/kundeb/orderListA/notes.txt`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}