import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<protocol>\\w+)\\s*request\\s*from\\s*(?P<source_address>\\d{1,3}.\\d{1,3}.\\d{1,3}.\\d{1,3}):(?P<source_port>\\d+)\\s*to\\s*(?P<destination_address>\\d{1,3}.\\d{1,3}.\\d{1,3}.\\d{1,3}):(?P<destination_port>\\d+).\\s*Action:\\s*(?P<action>\\w+).\\s*Rule\\s*Collection:\\s*(?P<rule_collection>[^\\s.]+).\\s*Rule:\\s*(?P<rule>[^\\s\\}]+)";
final String string = "UDP request from 20.0.1.42:34315 to 8.8.8.8:53. Action: Allow. Rule Collection: wfx-us-east-prod-allow-internet. Rule: allow-internet\n\n"
+ "TCP request from 162.158.79.116:45646 to 52.191.237.198:443 was DNAT'ed to 20.0.1.28:443. Rule Collection: wfx-us-east-prod-nat-rules. Rule: collector-02}}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}