$re = '/https?:\/\/blibli\.app\.link/';
$str = 'https://blibli.app.link/O9zR9frEkHb';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);