$re = '/ActiveParticipant.*?\sUserID=\"+?(?<atnaUserID>[^\"]+)\".+?UserIsRequestor=\"true\"/s';
$str = '1765 <86>1 2020-11-16T09:50:50+01:00 localhost testSyslogXds SOAP_KSW-RI-Z1_100000000000023_000000000000011 IHE+RFC-3881 [origin swVersion="4.7.0" software="Orchestra"] <?xml version="1.0" encoding="UTF-8"?><AuditMessage><EventIdentification EventActionCode="C" EventDateTime="2020-11-16T09:50:50.755+01:00" EventOutcomeIndicator="0"><EventID codeSystemName="DCM" csd-code="110110" originalText="Patient Record"/><EventTypeCode codeSystemName="IHE Transactions" csd-code="ITI-44" originalText="Patient Identity Feed"/></EventIdentification><ActiveParticipant AlternativeUserID="11000000000506150000169" NetworkAccessPointID="10.70.65.176" NetworkAccessPointTypeCode="2" UserID="2.16.756.5.30.1.107|2.16.756.5.30.1.107.4.2" UserIsRequestor="true"><RoleIDCode codeSystemName="DCM" csd-code="110153" originalText="Source Role ID"/></ActiveParticipant><ActiveParticipant NetworkAccessPointID="https://api.test.xad.ch/mpi/ws/iti44Service" NetworkAccessPointTypeCode="2" UserID="2.16.756.5.30.1.194|2.16.756.5.30.1.194.3.1" UserIsRequestor="false"><RoleIDCode codeSystemName="DCM" csd-code="110152" originalText="Destination Role ID"/></ActiveParticipant><AuditSourceIdentification AuditEnterpriseSiteID="2.16.756.5.30.1.107.4" AuditSourceID="KSW ddag Navision TEST"><AuditSourceTypeCode csd-code="4"/></AuditSourceIdentification><ParticipantObjectIdentification ParticipantObjectID="1069851^^^&2.16.756.5.30.1.107.4.2.1&ISO" ParticipantObjectTypeCode="1" ParticipantObjectTypeCodeRole="1"><ParticipantObjectIDTypeCode codeSystemName="RFC-3881" csd-code="2" originalText="Patient Number"/><ParticipantObjectDetail type="II" value="Mi4xNi43NTYuNS4zMC4xLjEwNy40LjIuMTA5MDM0MDQ3MDQ2MDE5MDQxLjE2MDU1MTY2NTAyMzkuMjE="/></ParticipantObjectIdentification></AuditMessage>
Ereignisaktionen';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);