$re = '/^([a-z][a-z];)(.*)(\/.*\..*)$/m';
$str = 'pl;castorama/unsub/Bold_User.php';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);